shwq.net
当前位置:首页 >> 为什么装了ApAChE还要装PHP呢 >>

为什么装了ApAChE还要装PHP呢

不是必须,不过现在大部分的PHP都是在Apache服务器下运行,集成包也都是集成Apache+PHP+MySQL软件,像wamp,xamp,phpstudy;你可以下一个安装,如果是在linux,还可以安装Nginx

你确定你已经能安装phpMyAdmin了?如果你已经能安装了那么说明你已经有了web服务器同时能解析PHP脚本了那么,只能说明你已经安装了PHP+apache+mysql或者是PHP+IIs+mysql了。

当然需要,因为apache中有PHP的配置信息,必须重启APACHE

是直接显示源码么,这样的话得配置Apache: DirectoryIndex index.php index.html SetHandler application/x-httpd-php SetHandler application/x-httpd-php-source LoadModule php5_module modules/libphp5.so

apache安装成功后还要安装php程序, 你可以先到http://www.php.net/下在php程序,一般下载压缩版的即可 配置php.ini文件 修改php.ini-dist (1)查找 extension_dir 把值修改为php默认路径 如:extension_dir = "E:\webserver\php5\ext" (2)查找...

是你的apache配置文件没写好,请检查一下是否有以下内容: (如果你用的是安装版,应该会自动帮你配置好的。如果你用的是noinstall版,那就要自己手工配置了。) # 加载php模块 LoadFile "/opt/php-5.3.1/php5ts.dll" LoadModule php5_module "/...

可以的,具体步骤推荐给你一个连接,上面有完整步骤 网页链接

php.ini是一个配置文件,如果你没有修改配置的话,就在你的php安装目录里; 查找方法: 在随便一个moudle就是你的控制器下,在一个类的方法下写上: echo phpinfo(); 然后访问该页面,你会看到配置信息,php.ini的文件位置也会看到的;

不需用,是集成的环境包,其中的a就是apache;m就是mysql;p就是PHP 不叫翻译软件的。。。 推荐用editplus编辑器,等你成熟了,直接记事本就可以了,好多人可以的哦

网站首页 | 网站地图
All rights reserved Powered by www.shwq.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com